Videos on My ACP Decisions Obscured By Language Lists
Incident Report for ACP Decisions
Resolved
This incident has been resolved.
Posted over 1 year ago. Nov 09, 2017 - 17:29 UTC
Investigating
Videos on the My ACP Decisions Web Application may be obscured by their corresponding language lists. This occurs in all web browsers. We are actively investigating and working with our video hosting provider to restore playback as quickly as possible.
Posted over 1 year ago. Nov 09, 2017 - 15:55 UTC