Server Maintence (Between 10am EST - 4pm EST)
Incident Report for ACP Decisions
Resolved
We were able to complete our security update earlier than expected. The process is now complete.
Posted about 1 year ago. Feb 19, 2018 - 16:47 UTC
Monitoring
In preparation for a significant upgrade later this month, we will be performing server maintenance today between 10am EST and 4pm EST as we update our security. We expect brief interruptions during this period.
Posted about 1 year ago. Feb 19, 2018 - 15:10 UTC